[Dica] Forçar instalação de extensão no firefox

Postagem de conteúdos não relacionado as outras áreas
Post Reply
User avatar
51M0N
Admin
Admin
Posts: 874
Joined: Fri Jan 02, 2015 2:06 pm

[Dica] Forçar instalação de extensão no firefox

Post by 51M0N » Sat Aug 19, 2017 12:12 pm

Galera esses dias estava precisando de alguns complementos que no Firefox (55.0.2) deixaram de funcionar, como tenho um vm windao xp toda desatualizada q uso para fazer uns testes, salvou minha vida...kkkkk
Resolvi instalar o Firefox 3.0 que podem ser obtido no link[1]

Image
Gosto de usar as seguintes extensões como hackbar, live http header, user agente switcher por questão de gosto e por praticidade, estava tendo muito problema com compatibilidade no firefox, dando uma pesquisa consegui ativar o que queria ..kkk. vamos aos comandos:

Code: Select all

about:config
na barra ‘localizar’ você ira digitar os seguintes opções.
Image

Você ira ter que verificar as seguintes opções no lugar de true coloque false, no lugar de false coloque true

Code: Select all

extensions.checkCompatibility.6.0 
xpinstall.signatures.required
extensions.checkCompatibility
browser.tabs.remote.autostart
browser.tabs.remote.force-enable
browser.tabs.remote.autostart.2
browser.tabs.remote.force-enable
extensions.checkCompatibility.31.0
Também criei os seguintes arquivos:

Cria um config.js coloque esse código abaixo

Code: Select all

//
try {
Components.utils.import("resource://gre/modules/addons/XPIProvider.jsm", {})
.eval("SIGNED_TYPES.clear()");
}
catch(ex) {}
Mova o config.js para o seguinte diretório

Code: Select all

Windows: C:\Program Files\Mozilla Firefox
(ou C:\Program Files (x86)\Mozilla Firefox )

Linux: /usr/lib64/firefox-< version >
(or /usr/lib/firefox-< version > )

Mac: /Applications/Firefox.app
Cria um config-prefs.js

Code: Select all

pref("general.config.obscure_value", 0);
pref("general.config.filename", "config.js");
Mova o config-prefs.js para a pasta do firefox defaults\pref

Code: Select all

(ex.: C:\Program Files\Mozilla Firefox\defaults\pref)
E da um restart no sistema e baixe os XPI e instale no firefox, caso utilize as extensões q utilizo, irei deixar os XPI para download[2]

Se mesmo assim não conseguir instalar você terá que mudar o arquivo install.rdf que se encontra dentro do xpi, veja um exemplo, de um dos meus arquivos

Code: Select all

   <em:minVersion>1.0</em:minVersion>
        <em:maxVersion>4.0.*</em:maxVersion>
      </Description>
Image

Se tudo der certo suas extensões vão esta instaladas, trabalheira danada, mas agora vou poder brincar

Inté galera =)




Referências
[1] https://ftp.mozilla.org/pub/firefox/releases/
[2] https://my.pcloud.com/publink/show?code ... hIUYJOn1WX
https://superuser.com/questions/956145/ ... b1/1191271
https://www.ghacks.net/2017/02/03/firef ... n-plugins/
https://www.ghacks.net/2016/08/14/overr ... quirement/
Image
"Você, eu, nem ninguém vai bater tão duro como a vida. Mas não se trata de bater duro. Se trata de quanto você aguenta apanhar e seguir em frente (...). É assim que se consegue vencer." by Rocky Balboa

Post Reply

Return to “Outros Assuntos”